Pagero Online - Disturbances in the connection towards Posti Messaging Oy

Incident Report for Pagero Service

Resolved

The incident impacting connectivity with Posti Messaging Oy has been successfully resolved.

The fix has been fully implemented, and the system has been closely monitored to confirm stability and normal performance. At this time, all services are operating as expected. Posti Messaging Oy are working on processing all the remaining documents.

We sincerely apologize for any inconvenience this may have caused.

If you have any questions, please contact our Support team
Posted May 19, 2026 - 15:56 CEST

Identified

We've been informed of a potential disturbance in the connection towards Posti Messaging Oy. It was identified around 14:37 CEST. Posti Messaging Oy identified the cause for this and they are working to fix it as soon as possible. The reported affected services are:

-Invoice Sending.
-EDI.
-Invoice Receiving.

They estimated that the services will be operational around 19.05.2026 17:30 CEST.

We apologize for any inconvenience and will post new updates as soon as we learn anything more.

If you have any questions, please contact our Support team
Posted May 19, 2026 - 15:45 CEST
This incident affected: Pagero Online.