Pagero Online - Delays in document processing

Incident Report for Pagero Service

Resolved

The issue has now been resolved and services are available and working as normal. We apologize for any inconvenience this might have caused.

If you have any questions, please contact our Support team
Posted Feb 16, 2026 - 13:07 CET

Identified

We have identified and resolved the cause of the issue.

We’re still working on processing a large queue of documents currently in processing and as such there are still delays for documents being delivered.

We apologize for any inconvenience and will post new updates as soon as we learn anything more.

If you have any questions, please contact our Support team
Posted Feb 16, 2026 - 10:40 CET

Investigating

We’re currently investigating reports of potential document processing delays in one or more services in Pagero Online that was identified at 8:30 CET.

This is resulting in documents currently taking a long time to be processed and delivered.

We apologize for any inconvenience and will post new updates as soon as we learn anything more.

If you have any questions, please contact our Support team
Posted Feb 16, 2026 - 09:28 CET
This incident affected: Pagero Online.