Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2026 - 12:00 CEST
Scheduled
As part of the roll-out of version 26.2.3-6 of the PPF, a service interruption is scheduled for Thursday 9 July, from 12.00 to 14.00.
Affected Services:
EDI Services No processing of incoming transactions No processing of outgoing transactions API services will be unavailable on Saturday The offline electronic invoicing directory on the portal remains available for viewing
Please feel free to contact Pagero support in case you need further information.
Posted Jul 09, 2026 - 08:03 CEST
This scheduled maintenance affected: Partner (Pagero Online).