We have successfully processed the document acknowledgements queue, and all systems are operating normally.
We apologize for any inconvenience this may have caused.
If you have any questions, please contact our Support team
Posted Jan 23, 2025 - 18:14 CET
Update
We continue our monitoring of the queue of document acknowledgements and will inform you as soon as we have further updates.
If you have any questions, please contact our Support team
Posted Jan 23, 2025 - 16:19 CET
Update
We are currently delivering documents without any delays. However, we are still monitoring the remaining queue of document acknowledgements.
We apologize for any inconvenience this may cause and will inform you as soon as we have further updates.
If you have any questions, please contact our Support team
Posted Jan 23, 2025 - 13:51 CET
Update
Our teams have reallocated resources to address the pending delays. The queue has already decreased, and we continue to keep a close watch. We will provide further updates as soon as more information becomes available.
If you have any questions, please contact our Support team
Posted Jan 23, 2025 - 12:17 CET
Monitoring
Pagero Online is experiencing some delays in the delivery of documents due to a higher workload between our services.
Our teams have reassigned the available resources, so we are monitoring the pending delays and expect to diminish this queue shortly.
We apologize for any inconvenience and will inform about any update as soon as possible.
If you have any questions, please contact our Support team