Log in issue Pagero Online

Incident Report for Pagero Service

Resolved

The issue has been resolved and all services are now available and operating normally. We apologize for any inconvenience this may have caused.

If you have any questions, please contact our Support team: https://www.thomsonreuters.com/en-us/help/pagero
Posted Mar 01, 2026 - 09:31 CET

Investigating

We want to inform you that we are currently experiencing a service outage. Our team is aware of the issue and is actively investigating the cause to resolve it as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your patience and understanding during this time. We will keep you updated on our progress and notify you as soon as the issue is resolved.
Thank you.
Posted Mar 01, 2026 - 06:24 CET
This incident affected: Pagero Online.