Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 16, 2025 - 17:00 CET
Scheduled
Our partner DocProcess has scheduled maintenance on January 16th from 17:00-20:00 CET.
During the maintenance window, processing of documents will be temporarily suspended. Once the platform is available again, all submitted documents will be secured and processed as usual.
Please note that this only impacts the Romanian document flow.
If you have any questions, please contact our Support team
Posted Jan 10, 2025 - 17:21 CET
This scheduled maintenance affected: Pagero Online.