Pagero TMS unreachable

Incident Report for Pagero Service

Resolved

The incident has been resolved.
Posted Mar 06, 2026 - 22:44 CET

Update

The system is available again. Logging in could still take a while longer. We will continue to monitor the situation.
Posted Mar 06, 2026 - 10:53 CET

Investigating

All parts of our system are currently unavailable. We are investigating the root cause.
Posted Mar 06, 2026 - 10:40 CET
This incident affected: Pagero TMS.