Pagero Online - Delay in document processing towards Posti Messaging

Incident Report for Pagero Service

Resolved

The delay in document processing has been resolved.
Posted Aug 08, 2025 - 14:01 CEST

Monitoring

A fix has been implemented and we expect documents to now be processed as normal. We are actively monitoring the document flow to ensure everything is functioning correctly.
Posted Aug 08, 2025 - 07:09 CEST

Investigating

We’re currently investigating reports of delays in document processing in documents sent from Pagero Online to operator Posti Messaging.
We are working on identifying the cause and impact on customers.

We apologize for any inconvenience and will post new updates as soon as we learn anything more.

If you have any questions, please contact our Support team
Posted Aug 07, 2025 - 13:30 CEST
This incident affected: Pagero Online.