All services are working as expected, although they will be all monitored during the weekend to ensure everything is working correctly.
We apologize for any inconvenience this may have caused.
If you have any questions, please contact our Support team
Posted Nov 07, 2025 - 19:39 CET
Identified
The root cause of the incident has been identified and a fix is being deployed.
Posted Nov 07, 2025 - 14:09 CET
Investigating
We’re currently investigating reports of a potential outage in one or more services in Pagero Online that was identified at 13:00 CET. We are working on identifying the cause and impact on customers.
We apologize for any inconvenience and will post new updates as soon as we learn anything more.
If you have any questions, please contact our Support team