On behalf of our partner Masters India

Incident Report for Pagero Service

Resolved

The issue has now been resolved and services are available and working as normal. We apologize for any inconvenience this might have caused.

If you have any questions, please contact our Support team
Posted Sep 15, 2026 - 15:50 CEST

Identified

We have been informed by our partner that the issue has been resolved. However, some documents may still remain in a pending status.

We are working to process the remaining documents as soon as possible.

If you have any questions, please contact our Support team
Posted Sep 15, 2026 - 13:07 CEST

Investigating

We have received information from our partner Masters India pointing to a disturbance since 10:00 am (CET) that could possibly affect the document flow towards the Indian Tax Authority (NIC). This may affect our customers who use the Indian Clearance service.

For more information from Masters India, see below.

We are currently experiencing a service disruption. Our team is actively working to resolve the issue, and we expect to restore service shortly.
Posted Sep 15, 2026 - 10:23 CEST
This incident affected: Pagero Online.