Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2025 - 15:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 05, 2025 - 14:48 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 05, 2025 - 14:47 CEST
Scheduled
Please be advised that the Pagero Support Portal will undergo scheduled maintenance on June 9th from 15:00 to 17:00 CET. During this time, we will be transitioning our Customer Portal and Knowledge Base from https://support.pagero.com/ to a new platform at https://www.thomsonreuters.com/en-us/help/pagero.
Impact: Access to the support portal and email communications may be intermittently affected during the maintenance window.
We apologize for any inconvenience this may cause and appreciate your understanding as we work to enhance our service offerings.
Thank you for your patience and support.
Posted Jun 05, 2025 - 14:46 CEST
This scheduled maintenance affected: Pagero Support Center.