We are still experiencing intermittent issues that may affect various services in Pagero Online. Our teams are actively working to restore full stability as quickly as possible.
During this time, customers may experience occasional disruptions or degraded performance.
We apologize for any inconvenience and will share further updates as soon as more information becomes available.
Posted Jul 04, 2026 - 07:39 CEST
Update
We are still experiencing intermittent issues that may impact various services in Pagero Online. Our teams continue to investigate the root cause and are working to restore full stability as quickly as possible.
Customers may continue to experience occasional disruptions or degraded performance during this time.
We apologize for the inconvenience and will provide further updates as soon as more information becomes available.
Posted Jul 03, 2026 - 23:32 CEST
Investigating
We are currently experiencing intermittent issues that may impact various services in Pagero Online. Our teams are actively investigating and working to restore full stability as quickly as possible.
Customers may experience occasional disruptions or degraded performance during this time.
We apologize for any inconvenience and will post new updates as soon as we learn anything more.