Issue with Received Documents Tab

Incident Report for Pagero Service

Resolved

The issue affecting the Received Documents tab in Pagero Online has now been resolved. Our team identified the root cause and implemented the necessary fix to prevent it from recurring.

Thank you for your patience while we worked on this. If you experience any further difficulties or have additional questions, please don’t hesitate to reach out.

If you have any questions, please contact our Support team
Posted Nov 20, 2025 - 13:53 CET

Monitoring

A fix has been implemented and we are monitoring the results.

If you have any questions, please contact our Support team
Posted Nov 20, 2025 - 12:11 CET

Investigating

We are currently investigating an issue affecting the Received Documents tab in Pagero Online. Our team is working to identify the root cause and will provide updates as soon as possible.

If you have any questions, please contact our Support team
Posted Nov 20, 2025 - 10:42 CET
This incident affected: Pagero Online.